No connection with ft-dc3-lc

Find answers to common installation issues with the WebLink Updater.
Post Reply
New User
Posts: 2
Joined: Sun Nov 18, 2018 4:43 pm

No connection with ft-dc3-lc

Post by SBB » Sun Nov 18, 2018 6:50 pm


I'm working on a fresh install of a Compustar/Firstech ft-dc3-lc remote start module. I'm using the Idata N14 T harness, going into a 2005 Nissan Altima. Also, I'm using the weblink USB cable.

I'm trying to do the initial flash of the module, however, weblink will not connect with the module. As far as I can tell, the module is powering up as it has a steady red flashing light on LED #2. I've:
- tried two different laptop computers
- making sure that the weblink software was downloaded before connecting to the module
- reinstalling the drivers numerous times
- tried hitting the retry button over 20 times (I saw on one of the forms that a dozen hits will force connect on some modules)
- tried using both the Idata link website, and the Idata / compustar website
- checked continuity on each of the wires for the four pin cable for the weblink module.
- made sure that all four pins were at the same level (not pushed in or bent) on the remote start module and and the weblink end
- checked for, and found, power on both sides of the 30 amp fuse on the T harness
- double checked all other connections

It is interesting that when I hit the retry button, in weblink, sometimes it'll say "no product found," and sometimes "module not detected"

Kind of pulling my hair out with this one, any help would be greatly appreciated :)

User avatar
Site Admin
Posts: 6587
Joined: Sun Oct 23, 2011 8:35 pm

Re: No connection with ft-dc3-lc

Post by Murph » Mon Nov 19, 2018 12:43 am

If you plugged the flasher into the computer before the weblink software was installed, then your computer tried to help you and installed the wrong driver. This can be corrected by running the FTDI driver, twice.

technical support: 1.888.820.3690 ext. 203 Monday through Friday
Brian Murphy
MECP Advanced Certified Installer
ADS Tech Support
Automotive Data Solutions inc.
8400, Bougainville, Montreal, QC.

New User
Posts: 2
Joined: Sun Nov 18, 2018 4:43 pm

Re: No connection with ft-dc3-lc

Post by SBB » Mon Nov 19, 2018 10:23 am

I appreciate the reply. I think I figured out where I went wrong though. I had the module fully installed when I tried to flash it. Spent some time watching you tube videos and noticed people were flashing their modules before installation. I completely disconnected the module from the car, and it connected just fine :D

Was just a foreign concept for me, to have a module/vehicle computer that would only communicate when disconnected from the vehicle. Weird, but whatever, just glad it was something simple :)

Post Reply

Return to “Weblink Updater”