[SOLVED] "Module not Detected"???

Find answers to common installation issues with the WebLink Updater.
Post Reply
New User
Posts: 4
Joined: Sat Mar 24, 2018 9:53 am

[SOLVED] "Module not Detected"???

Post by MFP123 » Sat Mar 31, 2018 11:51 am

EDIT: seems that Win10 is temperamental (emphasis on the MENTAL). Found a Win7 laptop and the Maestro was easily detected and flashed. Note that the USB cable DOES matter. If your PC doesn’t even recognize the module being plugged in, don’t even bother troubleshooting....find another cable. I had to buy a new one instead of trying to fiddle with the ones I already had. The LED indicator MUST turn on when you at least try to flash....otherwise you’re wasting your time.

Okay so a LOT of debugging and testing in the last 2 days.

Maestro SW
Windows 10, Ultimate, English
Internet Explorer 11.309 (Not using Edge or other browser)
Latest WebLink 6.3 plugin installed (done without the Maestro plugged in as recommended in the forums)

I finally found a USB Cable that does work and I'm getting the Windows "Ping" when it successfully connects.
I can see the device "WebLink (COM3)" in the Devices (Ports) manager and doesn't have a warning to it, so it's loaded properly.

Plug in the Maestro, launch Internet explorer (not Edge), log into iDatalink Weblink updater and gets error when trying to flash:

MODULE NOT DETECTED Please connect a module to your PC using a compatible RS-232/USB cable. RETRY"

Looking at the Maestro, the LED is on solid so.....ya, I'm plugged in......What am I missing?

ADS Team
Posts: 413
Joined: Mon Jan 15, 2018 2:18 pm

Re: [SOLVED] "Module not Detected"???

Post by JustinFerroni » Tue Apr 17, 2018 12:12 pm

You can also try hitting the "Flash Your Module" button multiple times in a row (13-15x) and it will usually recognize as well.
Justin Ferroni
Technical Support Specialist- Maestro
T: 514.807.2888
TF: 866.427.2999

Post Reply

Return to “Weblink Updater”