USB not detected.... AGAIN!

Find answers to common installation issues with the WebLink Updater.
Post Reply
New User
Posts: 1
Joined: Sun Jan 14, 2018 3:34 pm

USB not detected.... AGAIN!

Post by AndreUK »

Hi there,

Like many of the people in this forum I am receiving 'the USB not detected' message. I have followed your instructions meticulously, on no less than 3 separate PC's now, and have tested two separate USB cable connectors. I'm using Windows 10 (I.E). I have installed the drivers from your website BEFORE plugging the device in and still am getting the same message. Please note - the LED indicator on the Maestro never lights up - just thought I'd let you know as I've seen this comment in other threads.

My dash board is wide open - and I've spent the whole day trying to resolve this to no avail.

I'm based in the UK - but purchased the Maestro RR in the US over Xmas as I have a US imported Jeep Wrangler and am trying to fit a Kenwood Car play (DMX7704s).

Appreciate it might be best I connect with customer services - are we able to do this on Skype, else I suspect its going to be a long, expensive long-distance call for me from the UK.



User avatar
Dara DeGrand
ADS Team
Posts: 7530
Joined: Mon Dec 02, 2013 1:34 pm

Re: USB not detected.... AGAIN!

Post by Dara DeGrand »

If you look in your Device Manager, is the maestro showing up? It may show as an unknown device, or it may show as "Weblink".
Dara DeGrand
Maestro Technical Support Manager
Automotive Data Solutions Inc.
8400 Bougainville, QC
T 514.807.2888
TF 866.427.2999

New User
Posts: 2
Joined: Mon Feb 05, 2018 7:49 pm

Re: USB not detected.... AGAIN!

Post by age2017 »

hi everyone. i spend more than 6 hour with the same problem. and today i try something different.
i using win 7 ultimate. try this:
uninstall everything
open internet explorer and go to idatalink web and download and install again the Weblink Updater 6.3 Plugin but
do not plug the usbupdater yet.
soon the installation its done, go to IE internet options, go to advanced under reset internet explorer settings
click reset, its going to open a small window, check the option to deleted personal settings.
its going to ask to restart you pc. go for it.
pc is on, go to flash your module, its going to pop in the bottom asking to ( allow ), i always check ( allow all page ).
hopefully works for you and everyone!!!!!

New User
Posts: 1
Joined: Mon Feb 12, 2018 11:42 pm

Re: USB not detected.... AGAIN!

Post by jersdungeon »

I too am having this issue and have tried everything suggested here with not luck. Any other ideas?

New User
Posts: 7
Joined: Tue Feb 20, 2018 10:27 pm

Re: USB not detected.... AGAIN!

Post by wharriso »

I had that problem with my DSR1 this morning. I fixed it by plugging in the DSR1 then opening device manager, right-click on the computer name and select "scan for hardware changes". After that I open "Ports(COM & LPT)". It shows up as WEBLINK (COM6)".

I have to do that every time I plug the thing in. I guess it's just not quite "plug n play".

New User
Posts: 1
Joined: Wed Sep 25, 2019 6:30 am

Re: USB not detected.... AGAIN!

Post by neetabhale »

I faced same issue. Thank for suggestions, I hope it will work out.

Post Reply

Return to “Weblink Updater”