Kenwood DMX1057XR

Find answers to common installation issues with the WebLink Updater.
Post Reply
leets80
New User
Posts: 1
Joined: Sat Jan 23, 2021 9:57 pm

Kenwood DMX1057XR

Post by leets80 »

Struggling to get my radio to work. All I'm getting is a double red flash. I have reflashed my module 5 times now to make sure I've gotten the serial number correct. Everything is connected and I can't even get the radio to power up. I've confirmed power at the harness on the back of the radio. Not sure what I'm missing. Any help would be greatly appreciated.

User avatar
JustinFerroni
ADS Team
Posts: 843
Joined: Mon Jan 15, 2018 2:18 pm

Re: Kenwood DMX1057XR

Post by JustinFerroni »

Kenwood has a small cover that needs to be in place for the radio to power on. If you have 12v on red 12v on yellow and ground on the black at the radios harness and the radio does not power on its either cover needs to be installed or the radio is defective. I would contact Kenwood if the problem persists.
Justin Ferroni
Technical Support Specialist
ADS Maestro
T 514.807.2888
Maestro.Support@ADSdata.ca

TLR8ight
New User
Posts: 1
Joined: Wed Jun 09, 2021 7:29 am

Re: Kenwood DMX1057XR

Post by TLR8ight »

I too am having problems with my kenwood dnr1007xr! The HU keeps rebooting constantly and then sometimes it will work for an hour or so but then it goes back to rebooting lol! I took the Kenwood HU out of my 2017 f150 and hooked it up directly to a battery without the maestro RR and it worked fine for hours but a soon as I put it back into the truck hooked up to the maestro rr it goes right back to rebooting. Any help would be appreciated!

Post Reply

Return to “Weblink Updater”