Unable to flash to Universal Mode

Find answers to common installation issues with the WebLink Updater.
Post Reply
El_Cacto
New User
Posts: 3
Joined: Sun Mar 15, 2020 6:58 pm
Location: El Paso

Unable to flash to Universal Mode

Post by El_Cacto »

I'm trying to update a DSR1 to Universal mode from T-Harness mode. When I try to use the web version of the Weblink Updater, It shows that the device could not be unlocked. When I run the Weblink desktop app, it shows that it flashes successfully. But I'm unable to get a stable connection via Rockfords Perfect Tune app. When the DSR1 is only plugged in via USB, it will display as a bluetooth device in the app, and still shows that it's configured for a Vehicle Specific Toyota Harness, rather than Universal. Is there anything specific that needs to be done to change from T-Harness mode to Universal? I read in another post that if it's in T-Harness mode it won't boot up correctly if the vehicle harness is not connected. Any help would be greatly appreciated.

Chris LaRoche
Moderator
Posts: 143
Joined: Mon Oct 07, 2019 12:49 pm

Re: Unable to flash to Universal Mode

Post by Chris LaRoche »

Hi,

When flashing the DSR1, you will need to use Desktop as you've noticed. You'll want to flash the embedded device, vehicle firmware (other/universal in this case), and then the DSR1 updater program. Are you changing the vehicle it's installed in or is there something else you're trying to accomplish with this?

Thanks!
Chris LaRoche
Automotive Data Solutions
Technical Support - Maestro
MECP Master Installer

El_Cacto
New User
Posts: 3
Joined: Sun Mar 15, 2020 6:58 pm
Location: El Paso

Re: Unable to flash to Universal Mode

Post by El_Cacto »

I followed your instructions, by flashing the embedded device and then the vehicle (universal) firmware. Then moved over to the DSR1 updater software and ran the firmware update from there while the device was connected only via USB. The updates all show as being successful upon completion. When I reconnect and open the details from the DSR in the PerfectTune app, it shows as still having Firmware ADS-AR-DC-T01-256, instead of the ADS-AR-DC-UNI-256 v1.4. I no longer have the Toyota Avalon it was installed in previously and am trying to set it back up for a GMC Sierra. With the DSR1 plugged into a tested and working 12v source, the status light cycles through red, green, blue and then steady white, but no bluetooth connection at all.

User avatar
Zack Flynn
ADS Team
Posts: 929
Joined: Mon Dec 12, 2011 9:46 am

Re: Unable to flash to Universal Mode

Post by Zack Flynn »

Try using the Rockford DSR1 Updater to restore/clear the unit. There is a box you can check in their updater to reset everything. Then Go back and update the unit with the 3 updates as you have. Let us know
Zack Flynn
Automotive Data Solutions
Technical Support & MECP Master Installation Technician
Zachary.flynn@adsdata.ca

El_Cacto
New User
Posts: 3
Joined: Sun Mar 15, 2020 6:58 pm
Location: El Paso

Re: Unable to flash to Universal Mode

Post by El_Cacto »

Seems like no change after checking the box to restore factory settings from the DSR1 updater and running the 3 updates again.

Post Reply

Return to “Weblink Updater”